CVE-2017-2668 Amazon Linux Security Advisory for 389-ds-base: ALAS-2017-824

漏洞类别:Amazon Linux

漏洞等级:

漏洞信息

Remote crash via crafted LDAP messages:
An invalid pointer dereference flaw was found in the way 389-ds-base handled LDAP bind requests. A remote unauthenticated attacker could use this flaw to make ns-slapd crash via a specially crafted LDAP bind request, resulting in denial of service. (CVE-2017-2668 )

漏洞危害

Allows unauthorized disclosure of information; allows unauthorized modification; allows disruption of service.

解决方案

Please refer to Amazon advisory ALAS-2017-824 for affected packages and patching details, or update with your package manager.

Patch:
Following are links for downloading patches to fix the vulnerabilities:

ALAS-2017-824: Amazon Linux (389-ds-base (1.3.5.10-20.50.amzn1) on i686)

ALAS-2017-824: Amazon Linux (389-ds-base (1.3.5.10-20.50.amzn1) on x86_64)

ALAS-2017-824: Amazon Linux (389-ds-base (1.3.5.10-20.50.amzn1) on src)

0day

发表评论