CVE-2018-1000030 Ubuntu Security Notification for Python2.7, Python3.4, Python3.5 Vulnerabilities (USN-3817-1)

漏洞类别:Ubuntu

漏洞等级: 

漏洞信息

It was discovered that Python incorrectly handled large amounts of data.

It was discovered that Python incorrectly handled running external commands in the shutil module.

It was discovered that Python incorrectly used regular expressions vulnerable to catastrophic backtracking.

It was discovered that Python failed to initialize Expat’s hash salt.

漏洞危害

A remote attacker could use this issue to cause Python to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2018-1000030)

A remote attacker could use this issue to cause Python to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-1000802)

A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2018-1060, CVE-2018-1061)

A remote attacker could possibly use this issue to cause hash collisions, leading to a denial of service. (CVE-2018-14647)

Leave a Reply